VLC 3.0.18 Is Out with RISC-V Support, DVBSub Support Inside MKV, SMBv2 Improvements

VideoLAN’s popular VLC Media Player software has been updated to version 3.0.18, a maintenance and feature release in the 3.0 series of the application that brings various enhancements and bug fixes.

VLC 3.0.18 is here more than eight months after VLC 3.0.17 and introduces support for the RISC-V hardware architecture, DVBSub support inside MKV files, Y16 chroma support, as well as a major adaptive streaming update, notably for multiple timelines and WebVTT (Web Video Text Tracks Format).

This release also brings various enhancements to the application to improve seeking in OGG files, seeking in some fragmented MP4 files, playback of some FLAC files, SMBv1 and SMBv2 behavior, and FTP compatibility.

On top of that, VLC 3.0.18 fixes bugs and crashes from previous releases. For example, it addresses DxVA/D3D11 crashes on HEVC files with bogus references, color regressions with VAAPI/iOS and OpenGL output, as well as resizing issues with OpenGL on GLX/EGL/X11/XV, Direct3d9 texture stretching.

Also fixed is a crash and storage size issue with the libass library, the building of the GME plugin, video placement with CAOpenGLLayer, a vocaroo script issue, password search in the KDE Wallet Manager (KWallet) module, rendering and performance issues with older GPUs, and the Lua script for YouTube to allow throttled playback, but the developers note the fact that YouTube restrictions still prevent unthrottled playback.

Some bug fixes for macOS and Windows users are present as well in VLC 3.0.18, which you can download and install right now from Flathub as a Flatpak app on your favorite GNU/Linux distribution. Those of you who prefer compiling VLC from sources can download the source tarball from the official website.

Last updated 3 mins ago

Leave a Comment